【初心者向けチュートリアル】はじめてのアニメーション、作ってみよう!

超汎用2Dアニメーションツール OPTPiX SpriteStudioへようこそ!(以降、Sprite Studioとします)
SpriteStudioはゲームキャラクター用アニメーションの作成のほか、カットシーン、エフェクト、UI、など様々な用途に使える万能アニメーションツールです。

ここでははじめてSpriteStudioを使用いただく方に、はじめの第一歩を学んでいただくページになります。
こちらに書かれていることを順になぞっていただくことで、比較的かんたんにアニメーションを作ることができるようになります。

目次

SpriteStudio のアニメーションって?

アニメーションと言うとテレビなどで見るアニメーションを想像する方もいらっしゃるかもしれません。
TVなどのアニメーションは1コマ1コマを1枚の絵で書き連続表示しています。
その枚数は1秒間に数枚~最大24枚(日本の基本的なアニメーションの場合)もの絵を表示しています。(作品ごとに枚数は違います)

ですが、その枚数を個人で書くのはとても大変な上、コンピューター上にたくさんの絵を格納することは、メモリ容量の問題が発生します。(最近ですとギガを食われる…というような言い方ですね)
勿論動画でアニメーションを表示することも可能ですが、動画は容量をたくさん消費する上に、ユーザーの操作により状況がリアルタイムに変化するゲーム用途には使用しにくいデータ形式です。

SpriteStudioのアニメーションは、パターン毎に絵を書くことなく、基本の1枚の絵をバラバラにして管理し、パーツごとに位置や大きさや角度などを変化させて動きを表現、その情報をデータとして持たせたコンピューターに適したアニメーションツールです。
データ=数字の羅列なので、画像に比べると圧倒的にメモリ容量の消費が少ないので、ゲームに使用しやすいデータになります。
そして、時間軸も全てのコマを設定することはなく、1と10の時間のポーズを設定したらコンピューターがその間の2~9までを計算して表示してくれますので、1枚1枚絵を書くより圧倒的に手間が減りますので、個人制作に優しいアニメーション方式になります。その作り方もとても簡単です。それでは早速アニメーションを作成してみましょう!

SpriteStudio の基本的な構成

それでは、SpriteStudioをインストールしていない方は、ダウンロードを行いインストール後、起動してください。

・SpriteStudioのダウンロードはこちらから

そして基本を学びアニメーションさせるためのサンプルファイルもダウンロードしましょう。
下記のURLからデータをダウンロードしてください。

・サンプルファイルのダウンロードはこちらから

サンプルファイルのページには複数のサンプルが掲載されいますが、今回は”学習用サンプルファイル”をダウンロードしてください。

ダウンロードしたファイルはZIP形式で圧縮されていますので解凍し、中に入っているファイルを他のフォルダに移動してください。

※エクスプローラやファインダーではZIPファイルの中を確認することができますが、SpriteStudioではZIPファイル内のファイルに直接アクセスすることは出来ません。ZIPファイルは必ず解凍(もしくはZIPファイル内のファイルをZIPファイルの外にコピー)して利用してください

 SpriteStudio等のクリエイター向けツールは、同じ名前のファイルを拡張子で性格の使い分けを行うものが多くあります。

ファイルの中には、”.sspj”、”.ssae”、”.ssce”、”.png(画像)”の4つのファイルが格納されています。

※Windowsの初期状態ではファイルに付与された”.sspj”等の拡張子が見えないように設定されています。
 SpriteStudio等のクリエイター向けツールは、同じ名前のファイルを拡張子で性格の使い分けを行うものが多くあります。
 こちらを参考に拡張子を表示するように設定いただくことをおすすめします。

ファイルの役割は以下のようになっています。

.sspj アニメーション下記の3つを管理するファイルです。
.ssae アニメーションの時間軸にどこにパーツが有るかを格納した数値が入ったファイルです。時刻表みたいなものになります。
.ssce 画像に入ってる絵が、どこからどこまでが何パーツかを登録しているパーツです。住所録みたいなものになります。

画像(PNGなど)

ばらばらのパーツを詰め合わせた画像のファイルです。アルファチャンネル(透明色)付き画像はPNG形式の他、TGA形式、TIFF形式、PSD形式(レイヤーは統合されます)が読み込めます。(他、BMP形式やJPG形式も読み込めますが、アルファチャンネルは使用できません)

ひとまず、現時点は基本4つのファイルで1セットとだけ覚えておきましょう。

SpriteStudioが起動した直後はデータは空っぽの状態ですので、先程ダウンロードしたファイルを読み込みます。
「メニュー」>「ファイル」>「プロジェクト」を開く を選択し、先程ダウンロードしたファイルを格納したフォルダを指定し、サンプルのプロジェクトファイルである”spritestudio_sample_chara.sspj”ファイルを読み込みます。


.sspjファイルを読み込むことでプロジェクトファイルに紐づいたファイルの”spritestudio_sample_chara.ssae”、”spritestudio_sample_chara.ssce”、”spritestudio_sample_chara.png”を全部読み出してくれますので、画面にキャラクターが現れます。

※.sspjファイルを直接SpriteStudioにドラッグアンドドロップすることでも、プロジェクトファイルの読み込みが可能です。

SpriteStudioの基本画面

初期状態で表示されるウィンドウ

メインメニュー SpriteStudio全体の操作を行うウィンドウです。今回はファイルの読み出しや保存に使用します。
ツールバー

基本的な動作が設定されたアイコンがズラッと並んでいますが、今回は基本的な物だけ使用します。今回は赤矢印の箇所をONにしてください。

プロジェクトウィンドウ 読み込んだプロジェクトファイルで管理されているファイルの一覧が表示されます。
セルリストウィンドウ 登録されているパーツの一覧です。画像を.ssceで指定したファイルが並ぶ形です。
レイアウトウィンドウ

実際にアニメーションをエディットするメイン画面です。

※ マウスのホイールボタンをクリックしながらドラッグすると表示位置の変更(スペースを押しながらマウスドラッグでも同様の操作ができます)、マウスホイールで表示のサイズの変更が可能です

フレームコントロールウィンドウ ⑤のレイアウトウィンドウに表示されたパーツが時間でどこにどんな形になるかを設定するウィンドウです。
アトリビュートウィンドウ パーツに入れる情報を設定するウィンドウです。入力すると⑥のフレームコントロールウィンドウに情報が入った青点(キー)が点灯します。

タブで切り替えると表示されるウィンドウ(今回使用するもののみ)

セルマップウィンドウ

画像を④のパーツとして切り出しをするウィンドウです。初期状態はレイアウトウインドウのタブになっています。

表示されている物は、.ssceファイルに登録された画像ファイルです。

レイアウト情報ウィンドウ

アニメーションのサイズや基準となる位置を設定するウィンドウです。初期状態はアトリビュートウインドウのタブになっています。

各ウインドウの境界線をドラッグすると、表示サイズの調整が可能です。

それでは、ダウンロードしたサンプルキャラクターを使用してアニメーションを作ってみましょう。

SpriteStudioのアニメーション作成の手順

1:まず、アニメーションを格納するアニメーションファイル(.ssae)を作成しよう

先程のringo.sspjファイルを開くと、既に作成されたキャラクターが表示されます。

サンプルキャラクター

これは既にアニメーションが完成しているサンプルファイルですので完成見本とし、今回はこのキャラクタの素材を使用してサンプルと同じようなアニメーションを作ることを目標にします。

では早速始めましょう!

はじめに「プロジェクデータを格納するssae(アニメーションファイル)を新規作成します。

「プロジェクトウィンドウ」の「アニメーション」を右クリックし、コンテキストメニューから「新規作成」を選択します。

1からアニメーションを作成する場合は必ず必要となりますので覚えておいてください。

※ファイルを新規作成する時や削除するときなどに、”警告、この操作は取り消しができません。またこれまでに~”と警告のウィンドウが表示されますが、ファイル追加の場合は気にせず”はい”を選択して問題ありません。ファイルを削除する場合の警告は、作成したファイルが完全に削除されますので、慎重に操作を行ってください。

フォルダとファイルを選ぶためのウィンドウが開きますので、ファイルに名前をつけOKを押します。

(今回は名称はNewAnimation.ssaeとしています)

するとアニメーションファイルである.ssaeが作成されます。

作成した.ssaeファイルは、「プロジェクト」ウィンドウの「アニメーション」の中に、表示されます。

1つのプロジェクトファイル内に複数のアニメーションファイル(.ssae)をもたせることが可能です。

2:パーツを並べるレイアウトウィンドウの設定をしよう

レイアウト情報ウィンドウで、キャラクタを表示するための「基準枠」のサイズと基準点を設定します。

はじめにのプロジェクトウィンドウで今回作成したファイル(作例はNewAnimation.ssae)の「anime_1」を選択してください。

”Setup”はボーンとメッシュを使ったアニメーションを作成する際に必要となりますが、今回はこちらは使用しません。

のレイアウトウィンドウの背景が青く、左上に「Animation」と表示されていればOKです。
のレイアウトウィンドウの設定をするのレイアウト情報ウィンドウはアトリビュートの下部のタブを切り替えると表示されます。

今回は右のように設定してみてください。

基準枠のサイズは作成するアニメーション全体の大きさです。

基準点はゲームなどで使用使用する際、この中心にプログラムで背景の高さを値を足すことでキャラクタの立ち位置が変化させることができるようになります。

キャラクタが何を見るかにより変化します。例えば天井に張り付いたキャラなどは中心は上になります。また空中を飛び回るキャラなどは中心に設定したほうがぐるぐる回ることができますので便利になります。

今回は地面に立つことになりますので基準点は地面に作るように下に設定します。

基準枠や基準点を入力するとのレイアウトウィンドウの見え方が変化します。

基準枠の設定はゲームなどで使用使用する際、この中心にプログラムで背景の高さを値を足すことでキャラクタの立ち位置が変化させることができるようになります。
ゲームなどで使わない場合は厳密でなくてもいいですが、キャラクタを動かす目印になりますので設定をしておいたほうが良いでしょう。

またレンダリング(画像の出力)をする際、この枠が切り出されるのでキャラクタの動きを想定したサイズにしておくと良いですが、枠サイズはあとからキャラクタの動きを見ながら調整もできます。

※ マウスのホイールボタンをクリックしながらドラッグすると表示位置の変更、マウスホイールで表示のサイズの変更が可能です

※基準枠のサイズはゲームなどで使わない場合は厳密に設定しなくて問題ありませんが、キャラクタを動かす際の目印になりますので設定をしておいたほうが良いでしょう。

基準枠は動画やアニメーションGIFなど作ったアニメーションを活用するためのレンダリング(画像の出力)をする際、切り出すサイズにもなります。

3:新たにパーツを登録していこう

のセルリストウィンドウにパーツが沢山登録されています。
この中から”body”というパーツを見つけ出し、のセルリストウィンドウからのレイアウトウィンドウにドラッグアンドドロップします

また、のフレームコントロールウィンドウにも同じパーツが登録され、リストになっていきます

のレイアウトウィンドウにパーツが配置されたら、”2”で設定した地面の位置を見ながらこのあと足が入ることを考えて、おおまかに位置調整しましょう。(後で調整可能ですのでおおまかで構いません)
なお、一番はじめに”body”を配置しましたが、人体の動きの基準は基本腰のあたりになります。体が動いたら、腕、足、頭などが一緒についてくるようにするためです。

※リスト上でマウスのホイールを回転すると、リストがスクロールします。

“body”が配置し終わったら、のセルリストウィンドウから”skirt”を探し、のレイアウトウィンドウへドラッグアンドドロップしスカートとして”body”に重ねます。

次にのセルリストウィンドウから右足と左足として”leg”を2つののレイアウトウィンドウへドラッグアンドドロップします。

のレイアウトウィンドウに配置されたら”skirt”に足の根本がつながり先が横の緑の点線に接触する感じに配置します。(この時点で体の位置を調整しても問題ありません)

同じパーツを2つ入れると混乱しやすくなるので、パーツの名前をつけなおすとよいでしょう。

のフレームコントロールウィンドウのリストをマウスでダブルクリックすると名称変更が可能です。

※パーツを選択際はのフレームコントロールウィンドウリストのパーツを選択するとのレイアウトウィンドウに表示されたパーツに枠がフォーカスされます。

逆にのレイアウトウィンドウのパーツを選択するとのフレームコントロールウィンドウのリストのパーツも同時に選択という感じに連動しています。

またのセルリストウィンドウのパーツものレイアウトウィンドウやのフレームコントロールウィンドウで選択されたパーツにフォーカスされます。

続けて”arm”と”head”と”tail”を配置します。

見た目が変になると思いますが、ひとまず全てのパーツをならべてください。

(服についている”himo”や頭の”tail”、装飾の”apple”は必須ではありません。今回の作成では片方だけ頭に”tail”をつけています)

4:パーツの前後の見た目がおかしい? ”優先度”を設定して解消しよう

パーツを登録していくとパーツの見た目がおかしくなるかもしれません。

これはパーツの前後関係の設定である「優先度」が設定されていないためです。

パーツを登録したばかりの時点では、この優先度は全て同じになっています。
左の腕を試しに動かしてみると首の下に入り込んでしまっています。
これを避けるのが優先度です。

のレイアウトウィンドウでパーツをクリックし選択すると、のアトリビュートウィンドウの選択したパーツに対する項目がアクティブになります。

パーツの前後関係はのアトリビュートウィンドウの”優先度”で設定を行います。

優先度は体を0とした時、手前にしたいものは+、奥にしたいものは-の値にしていきます。

頭は首の手前にしたいので+1、その手前に手が回り込むようにしたいので左の手は+2、左の足は体の奥にしたいので-1、奥の腕はそのまた奥にしたいので-2…というように数値を設定していきます。
今回のキャラクタはこのような形で設定を行います。

この時点で再度パーツの位置関係を調整しても問題ありません。

なお、優先度の数値は1234…と1単位でなく、2468…というように1つ置きなどで設定しても構いません(数字に隙間があったほうが後でパーツの追加がしやすくなります)

5:パーツとパーツを繋げて関節構造を作ろう

パーツの配置が終わりましたが、現在のままではパーツとパーツがつながっておらず、体を動かして手や足や頭が置いていかれたまま動いてしまします。

そこでパーツ同士の関係を構築して従属関係を設定します。

この関係を親子関係といい、親を動かした時は子供が動くが、子供を動かしても親は動かない関係になります。
WindowsのエクスプローラやMacのファインダー等のファイルを扱う際、親フォルダを移動すると小フォルダも全て移動するが、小フォルダを移動しても親フォルダは残る…という関係と同じ構造になります。

設定の仕方はファイルの操作とよく似ています。
まずは体に足をつけましょう。のフレームコントロールにあるリストの”head”を選択し、”body”へドラッグアンドドロップします。
この時リストの右側か左側かどちらにドロップするかで結果が変わります。(左側はパーツのリスト位置移動、右側は親子関係になります)
なので右側にドロップしてください。

リスト左のように階層状になれば成功です。

これで”body”と”head”は親子関係が成立しました。

左のようになった場合は、パーツのリストの位置だけ移動しています。(リストの左側にドラッグしたり、パーツとパーツの合間に入れていると思われます)再度”body”にドラックアンドドロップしてください。

同様に、手やしっぽ、頭も設定します。顔のパーツは頭の子供になるようにします。
“body”>”head”>”tail”のパーツ という2段階の親子関係になります。

通常足は腰のパーツがあれば腰の子として足をつなぎますが、今回はスカートで隠れた部分のパーツは存在しませんので、体の子にしています。

スカートは足とは繋げず体の子にしています。(スカートに足をつけてしまうと、スカートを動かした際一緒に足が動いてしまう為です)

 

最終的に右の画像の状態になるように親子関係を設定してください。

また、この時点でパーツやキャラクタの表示位置を調整をしても問題ありません。

6:試しに動かして、親子関係や前後関係がおかしくないかチェックしよう

※初期ポーズを保持したいのでこの時点でファイルを保存しましょう。また、手戻りが発生しそうなタイミングでは、保存するクセを付けるのが望ましいでしょう。

ファイルの保存はの「メニュー」>「ファイル」>「プロジェクトの保存」で行います。(プロジェクトの保存を行うことでプロジェクトで管理されているファイルで内容に変化ががあったものは一括で保存されます)

のレイアウトウィンドウでパーツを選択すると右画像のようなハンドルが表示されます。この赤丸をドラッグすると赤丸から伸びる青線の先を軸として関節を曲げることが出来ます。

パーツの親子関係のつながりや優先度の前後関係をチェックしながら、パーツを回転させたり移動させたりしていろいろポーズをつけてみてください。

もし手を回転したら足にめり込んだ…などがあったら優先度の値を見直してください。

7:アニメーションの時間を設定しよう

まずFPSを設定します。初期状態は30FPSになっていますが、これは1秒間に30パターンで再生するということになります。
ゲームでは通常30FPSか60FPSを使用し60FPSの方がスムーズに動きますが、タイムラインが長くなりますので今回は30FPSのままにします。
次にフレーム:0/10 の箇所に注目します。時間軸のメモリのことをフレームといい、左の枠は現在の時間位置を示すスライダがある位置を表し、右の四角はこのアニメーションのフレーム数を表します。
初期状態は10の数字が入っていますが、30FPSですので1秒の3分の1の長さしか無いことになります。
この値を変更すると全体の長さが変化しますので、歩くのに適した長さとして40の数字を入れます。
数値を入れると確認ダイヤログが開き、「キーフレームの位置を調整しますか」と確認されますが、今回ははい、いいえのどちらでも構いません。
※アニメーションを作成後に長さ調整する際数値を大きくすると、はいを選択すると現在のアニメーションの時間が引き伸ばされ、いいえを選択した場合は空き時間を後ろに付け足す形になります。
 短くする場合ははいを押すと圧縮され、いいえを押した際は後ろがカットされます。(特に数値が少なくなる際は、設定した情報が省略される場合がありますので注意)
するとタイムラインが長くなり、1秒+1/30の長さで歩きを作れるようになります。

8:いよいよアニメーション作成本番

おまたせしました、いよいよアニメーションの作成です!

のフレームコントロールウィンドウのメモリ部のスライダを0に合わせてください。

のレイアウトウィンドウで手足を上げ、踏み出したようなポーズを作成してください。

この時右足を前に出した時は右手は後ろ、左足を後ろに下げた場合は左手は前と逆の方向に動かすことになります。
※動きの基本は実際に自分で動いてみて確認するとよいでしょう。

ポーズが出来たら、先頭と終わりを同じポーズにして、ループできるようにします。
0フレーム目にタイムスライダを合わせ、0フレーム目のキーを全て選択し、マウスの右クリックでコンテキストメニューを表示、コピー”全て”(もしくはCTRL+C)を選択します。

のフレームコントロールウィンドウに並んだ青い丸中身はのアトリビュートウィンドウに並んだ項目の情報となり、パーツの座標や回転角度、不透明度など、様々な情報が設定されます。

”4”の工程で設定した優先度も設定されています。

リストの先頭の”キー”の欄にある丸印は、情報の有り無しを表します。

灰色の丸は未設定となり、情報が存在するものは青丸で点灯します。

なおパーツ配置時に最低限必要な情報は自動的に設定されています。

※フレームコントロールの枠の操作について

EXCELの列選択と同様の操作で、上から下まで一律で設定しますよという状態です。(同様にCTRLを押しながら、クリックすると表の離れた箇所を個別に選択することが可能です)

39フレーム目の”root”、もしく”body”にマウスを合わせ、マウス右クリックで貼り付け”上書き”(もしくはCTRL+V)をします。

すると、0フレーム目のものが39フレーム目に丸ごと移植されます。

2”root”は基本動かしませんので、0フレーム目に情報があれば0フレーム以外にコピーしなくても問題ありません。

次に中割りを行います。
タイムスライダを19フレーム目にスライドさせます。

※注意:タイムスライダが赤い場合は、そのスライダの時間以外のパーツが選択されている状態です。移動した時間のパーツの設定を行いたい場合は、パーツの選択をし直してください。スライダが黄色になればOKです。

手と足を逆の位置に回転させてください。
腕が前に出ている場合は後ろに、足が後ろにある場合は前になります。左右とも動かします。

動かすとフレームコントロールウィンドウの19フレームの手足にキーが記録されます。

これでアニメーションのための情報が登録されました。

 

9:アニメーションを再生しよう

早速アニメーションさせてみましょう!

フレームコントロールのこのマークがONになっているか確認します。ONになっていればループ再生になります。
確認できたら▶を押します
するとアニメーションします!
作業としては始めと最後と真ん中の設定を下だけですが、設定の合間はコンピューターが計算して表示しますのでこれだけの作業でアニメーションが成立します。
これがSpriteStudioのアニメーションです。

10:…なんか動きが不自然じゃない?そう思ったら作り込み!

一応アニメーションはしました!

が、なにか不自然さを感じるかもしれません。

不自然さの大きな原因は空中を滑っているように見えるからかも?
なので地面を歩いているように調整してみましょう。

タイムスライダを0の位置に移動し、”body”のパーツを選択します。
選択したらレイアウトで足が地面に接触する感じに移動させてください。

※マウスで移動すると横にも動いてしまいがちです。

縦だけ動かしたいなと思った時は、アトリビュートのY座標の数字をクリックし、表示された三角形をマウスでクリックすると数値を変更できます。
またダイレクトに数字を入力することも可能です。

Y座標の文字の上をマウスで左右にドラッグすることでも数値入力が可能です。

接地できたら0フレーム目の”body”のパーツを1クリックし、”Body”のキーのみを選択し、マウス右クリックのコンテキストメニューのコピー”全て”(もしくはCTRL+C)でコピーします。

39フレーム目の”Body”のキーを
クリック選択&右クリックでコンテキストメニューを表示し、キーをペースト(もしくはCTRL+V)します。
19フレーム目にも同様にペーストしてください。
ためにしアニメーションを再生させてみましょう。
すると今度は設定したキーとキーの真ん中のあたりで足が地面にめり込んでしまっています。

ですので、一番めり込んでいる10フレーム目あたりの”body”のキーを選択しY座標をめり込まないように上に上げてください。

30フレーム目も同様にめり込まないように移動します。

再生してみましょう。
すると14の設定直後の不自然さが抜け地面を歩いているように見えるようになりました。

その他の動いてない頭や髪の毛を動かすことによって不自然さがどんどんなくなっていくと思いますので、色々試してみてください。

※左は”head”、”tail”、”skirt”にZ回転を加えました。

これで基本的なアニメーションの作成の仕方は完了です。
どうでしょうか?比較的かんたんに40パターンもあるアニメーションが出来てしまいました。

勿論サクサク作るには慣れもあります。
今回ご説明した感じで3~4キャラクターも作成すれば大分分かってくるのではないかと思います。
またサンプルファイルの方でも他のアニメーションがありますので参考にしながらいろんなアクションの作成にチャレンジしてみていただけたらと思います。

作成したアニメーションを出力してみよう

作成したアニメーションは、動画やアニメーションGIFやアニメーションPNG、アニメーションWebPなどに出力(レンダリング)し、Xのツイートや画像投稿サイトの投稿画像、SNS向けスタンプ画像の作成や動画の素材などに活かすことが出来ます。

※このページに貼り付けられているアニメーションは、SpriteStudioで直接出力したものを使用しています。

レンダリングは「メニュー」>「アニメーション」>「レンダリング」から行うことが出来ます。

レンダリングを選択すると、下記のウインドウが開きますので、目的に合わせ設定します。さしあたり下記を設定するとよいでしょう。

他レンダリングは設定でいろいろなことが可能です。詳しいことを学びたい場合は下記のページを参考にしてください。

レンダリングの詳細はこちら

また、本格的にゲームに組み込む場合は、弊社で提供しているゲームエンジン用のプレイヤーを組み込むことでSpriteStudioのアニメーションをそのまま再生することが可能になります。(プレイヤーの組み込みについては難易度が上がりがますので、プログラマさんの協力が必要かもしれません)

アニメーションデータの使用方法

自分で新規パーツを登録してみよう

上記はすでにあるサンプルファイルを元にしましたが、勿論自分書いた絵を登録することが出来ます。
PNGファイルやPSDファイル(レイヤーは統合されます)、TGAファイルなどのアルファチャンネルが設定される画像を用意し、SpriteStudioにドラッグアンドドロップするだけでオリジナルの画像の登録ができます。
(SpriteStudioへの画像取り込み時に自動的に.ssceファイルの作成が行われます)
絵を取り込んだら次の工程を行ってください。

1:まず初めに新たな絵を追加します。Windowsのエクスプローラ、Macのファインダーを開き、画像を選択、SpriteStudioへドラッグアンドドロップすることで新たに絵を追加することが出来ます。

2:ファイルをドロップすると、ウィンドウが開き「コピー先のフォルダとファイル名を指定してください」と表示されますので、現在存在するプロジェクトに追加する場合は、プロジェクトファイルのあるフォルダを指定し、名前をつけて保存ボタンを押します。これで画像が登録されました。

 

3:続けて「セルマップの新規作成」を促されますので、画像と同様に名前をつけて保存します。

 

※新規に追加したパーツは、新たな.ssceファイルに記録されています。

今まで作成していたキャラクタのデータを加工する際はプロジェクトウィンドウのセルマップの項目で聞いりかえが可能です。

(レイアウトウィンドウや、フレームコントロールウィンドウのパーツを選択した際は自動的に切り替わります)

 

4:次に追加した画像をセルリストに並べるセルパーツにします。

レイアウトウィンドウと重なっている(見当たらない場合はメニュー>ウィンドウ>セルマップを選択)”セルマップ”を開きます。

 

5:⑤のレイアウトウィンドウに取り込んだ画像が表示されますので、パーツを左上から右下に囲うように左クリックしながらマウスをドラッグします。

6:マウスで囲んだ枠をダブルクリックします。するとセルリストに新しいパーツが登録されます。
 ※新規のプロジェクトファイルでなく、既存のファイルに画像を追加した場合は、既に登録されている画像と.ssceファイルとは別のファイルとして登録されます。

追加した画像はプロジェクトウィンドウのセルマップのリストに登録されますので、既に登録した絵を選択したい場合はそちらを切り替えてください。

 ※既存の画像自体に絵を付け足すことも可能です。その場合は絵を追加し保存したあとに、プロジェクトウィンドウのセルマップのファイル名を右クリックしコンテキストメニューを表示し、”参照イメージのリロード”を選択し、2~4の工程を行うことで既存のセルマップにパーツを追加することが出来ます。

7:回転軸の設定をします。セルリストのパーツをクリックするとセル編集ウインドウが新たに開きます。黄色い十字線がありますので、これを移動することで回転軸の設定ができます。
(サンプルのパーツは回転軸は設定済みでしたが、自分で絵の登録をする場合は回転軸の設定は必須になりますのでご注意ください)

今回は手で持つ場所に移動します。

ウィンドウを閉じると原点設定が確定します。

ウィンドウを一旦閉じたあとに、再度原点設定を行いたい場合は、④のセルリストのパーツをダブルクリックすると再度セル編集ウィンドウを開くことが出来ます。

※サンプルのパーツは原点は設定済みでしたが、自分で絵の登録をする場合は追加の都度原点の設定は必須になりますのでご注意ください。

8:回転軸が設定できたら、今までと同様にレイアウトに追加しアニメーションを作成していきます。

学んだことを元にパーツを追加していきます。

ハンマーを手に保たせる場合は、親子関係で手の子にし、手のひらのあたりに設置します。(右はarm_rの子にしています)

前後関係がおかしい場合は優先度を見直します。

キャラクタにハンマーを持たせることが出来ました。

自分で用意した絵をもっと簡単に絵を登録してみたい!

 やっぱり自分の絵でアニメーションを作りたいですよね!

 ですが、絵を描いてバラバラの状態を画像に入れてセルマップを登録して~となるとなかなか面倒です。
 そこでAdobe PhotoshopやCLIP STUDIO PAINTで作成出来るレイヤー毎に書いた絵をPSDファイルとして保存し、そちらをSpriteStudioへ見た目そのままに登録できる機能があります。
 (今回はSpriteStudioのアニメーション構成を知っていただくため、こちらの紹介をあとまわしにしました)
 下記を利用いただくことで”3”の工程を大幅に簡略化出来ますので是非ご利用ください。

 PSDファイルインポート機能の説明はこちら

次なるステップはこちらのページから詳しく 入門書もあります

入門編はこちらで終了になります。

もっと複雑なアニメーションを作成してみたいと思った方は…
ヘルプセンター本体や次のページを読んでみてください。

またSpriteStudioビギナーズという入門書のPDFもありますので、そちらもぜひご覧ください。

・もっとSpriteStudioの表示されているものの意味を知りたい>ヘルプセンター本編へ

・複数のアニメーションを合成してみたい(インスタンス機能

・キャラクタを柔らかく動かしてみたい(ボーン&メッシュ機能)

・エフェクトを作ってみたい(エフェクト機能)

・キャラクタの一部が欠けるような描写をしてみたい(マスク機能)

・その他盛りだくさん!SpriteStudioの機能一覧

・入門書:SpriteStudioビギナーズ2配布はこちら (PDF配布)