イメージの領域選択

イメージのコピーや切り抜きを行うには、まず「領域選択」を行う必要があります。

選択モード

猫の絵の領域を選択

▲猫の絵の領域を選択

四角形選択モードに移行するには、編集モードウィンドウの「領域選択を行うモード」のアイコンをクリックします。

[四角形選択]

[四角形選択]

ドラッグで四角形の領域を選択することができます。
[Shift]キーを押しながらドラッグしている間は、「四角形選択縦横比」で指定した比率の四角形に固定されます。
選択領域を8ドット・16ドットなどの単位にスナップしたいときは、メインメニューから[設定]-[四角形選択単位]を選びます。

[楕円選択]

[楕円選択]

ドラッグで楕円の領域を選択することができます。
[Shift]キーを押しながらドラッグしている間は、正円に固定されます。

[ドット選択]

[ドット選択]

ペンで塗り潰すようにして領域を選択することができます。

[なげなわ選択]

[なげなわ選択]

フリーハンドで描いた線の内側の領域を選択することができます。

[マジックワンド選択]

[マジックワンド選択]

クリックした点の色に近い色の領域を選択することができます。

selection_wand_param

▲しきい値

編集モードウィンドウ下部の[しきい値]で、「近い色」の範囲を指定することができます。

 

数値入力で領域選択

数値で座標を入力して領域選択を行うには、メインメニューから[編集]-[領域選択]を選びます。

条件指定で領域選択

色などの条件を指定して領域選択を行うには、メインメニューから[編集]-[ピクセル条件選択]を選びます。

すべて選択

イメージ全域を領域選択するには、メインメニューから[編集]-[すべて選択]を選びます。

選択の取り消し

領域の選択状態を解除するには、メインメニューから[編集]-[選択の取り消し]を選びます。選択領域の外側をクリックしても、解除することができます。

選択領域の反転

メインメニューから[編集]-[選択の反転]を選ぶと、選択されている領域と選択されていない領域を反転させることができます。

選択領域の大きさを変更する

選択領域が四角形のときは、領域の枠をマウスで掴んでドラッグすると、選択領域の大きさを変更することができます。
また、[編集]-[選択領域拡大/縮小]を選ぶと、選択領域を1ピクセル広げたり、狭めたりすることができます。

選択領域の追加と削減

▲選択領域を追加

▲選択領域を追加

[Shift]キーを押しながら領域選択操作を始めると、マウスカーソルがptr_selection_addになり、現在の選択領域に新しい選択領域を追加することができます。
同様に、[Alt]キーを押しながら領域選択操作を始めると、マウスカーソルがptr_selection_subになり、現在の選択領域から選択した部分を削っていくことができます。
これらのキーの判定は「ドラッグを開始する時」に行われます。ドラッグを始めたら、キーを離してもかまいません。
ドラッグ中の[Shift]キーは「四角形の縦横比固定」や「正円の固定」に使用します。

選択領域を移動する

選択領域の内側をマウスで掴んでドラッグすることで、選択領域を移動させることができます。このとき移動するのは選択領域のみで、選択領域内のイメージは移動しません。

選択状態の編集

▲選択領域を追加

▲選択領域を追加

メインメニューから[編集]-[選択状態の編集]を選ぶと、選択領域の形状(選択状態)の保存や復元を行うことができます。

選択状態のコピー

選択状態をクリップボードへコピーします。
[編集]-[コピー]などでイメージをクリップボードへコピーしたとき、同時に選択状態もクリップボードへコピーされます。このときは、「現在の選択領域が収まる最小の四角形」に切り取られた選択状態がコピーされます。

選択状態の貼り付け

クリップボードへコピーした選択状態を編集中のイメージに再現します。

選択状態の拡張貼り付け

クリップボードへコピーした選択状態を編集中のイメージと合成します。

選択状態の読み込み

ファイルへ保存した選択状態を読み込み、編集中のイメージに再現します。

選択状態の保存

現在の選択状態をファイルへ保存します。
選択状態ファイルの拡張子は、”.iss”です。

選択領域の表示

選択領域は、さまざまな方法での表示制御を行うことができます。

ガイドマスクを表示する

選択領域枠とともに、領域の内側(または外側)を示す塗り潰し領域を合成表示させることができます。この表示を「ガイドマスク」と呼びます。
ガイドマスクを表示するには、メインメニューから[表示]-[選択領域ガイドマスク]をONにします。
ガイドマスクの色や濃度、内側/外側の設定を行うには、[環境設定 – 補助機能 – 選択領域ガイドマスク]ダイアログを開きます。

選択領域の表示方法を選ぶ

選択領域の描画方法はいくつかの設定が用意されており、システム負荷と扱いやすさのバランスに応じて選ぶことができます。描画方法を選ぶには、メインメニューから[環境設定]ダイアログを開きます。

 

選択領域の表示を隠す

選択領域の表示を一時的に隠すには、メインメニューから[表示]-[選択領域枠一時非表示]をONにします。OFFにすると、元通り表示されるようになります。

選択領域への操作

選択した領域内のイメージは、移動したり、クリップボードへコピーしたり、切り抜いたりすることができます。

選択領域部分のイメージをコピーする

選択した領域内のイメージをクリップボードへコピーするには、[編集]-[コピー]を選びます。コピーしたイメージは、imestaや他のアプリケーションに貼り付けることができます。

選択領域部分のイメージを移動する

選択した領域内のイメージを移動するには、編集モードを[移動]にしてからドラッグするか、または矢印キーを押します。
イメージをナッジ(移動元のイメージを残したまま移動)するには、同じく移動モードで[Alt]キーを押しながら矢印キーを押します。
この他の操作については、「イメージのコピーと貼り付け」をご覧ください。

選択領域部分のイメージを切り取る

選択した領域内のイメージをクリップボードへコピーしたあと、選択色で塗り潰す(カットする)には、メインメニューから[編集]-[切り取り]を選びます。

選択領域部分のイメージを切り抜く

選択した領域の外側を捨てて、内側だけ切り抜いたイメージを作るには、メインメニューから[イメージ]-[切り抜き]を選びます。
選択領域が四角形でないときは、「選択領域がすべて収まる最小の四角形」に対して作業を行います。

選択領域部分を塗り潰す

選択した領域内を指定した色で塗り潰すには、メインメニューから[編集]-[ピクセル初期化]を選びます。
選択色で塗り潰すには、同様に[編集]-[クリア]を選ぶこともできます。

画像処理やフィルタ

各種画像処理やフィルタ処理では、「選択領域に対して作業」するための指定項目があります。これを用いると、画像の一部分だけに処理をすることができます。

イメージを貼り付ける

クリップボードへコピーしたイメージを貼り付けるには、メインメニューから[編集]-[貼り付け]などを選びます。普通の貼り付けのほか、特定チャンネルだけの貼り付けや、透過色を指定しての貼り付け、アルファ値を反映しての貼り付けなど、いくつかの作業を選ぶことができます。

領域選択の移動単位を指定する

四角形選択モードで、選択領域を8ドット・16ドットなどの単位にスナップしたいときは、メインメニューから[設定]-[四角形選択単位]を選びます。

[Ctrl]キーを押している間は、

  • 領域選択単位が1ドットのときは、8ドット単位の移動
  • 領域選択単位が1ドット以外のときは、1ドット単位の移動

になります。

キーボード操作

カーソル 選択領域枠を移動します。(※)
[Shift]+カーソル 選択領域枠の大きさを変更します。
[Alt]+カーソル 選択領域枠内のイメージをナッジします。
[Ctrl]+A 全領域を選択します。
[Ctrl]+D 選択領域を取り消します。
[+] 選択領域を拡大します。
[-] 選択領域を縮小します。

[Ctrl]キーを押している間は、四角形選択単位が1ドットのときは8ドット単位の移動に、1ドット以外のときは1ドット単位の移動になります。

このエントリーは役に立ちましたか?