追加したアニメーションの絵が表示されない原因を知りたい

追加したパーツの画像がレイアウトウィンドウに表示されない場合、以下の項目をご確認ください。

パーツの画像が表示されない

アニメーションデータを「追加」した際に、パーツの画像が表示されない場合、「参照セル」のアトリビュートの設定が無効になっていたり、セルが削除されている可能性があります。

「参照セル」のアトリビュートが無効になっている

「参照セル」アトリビュートがWindow_Attribute_icon02_ver5.6.1無効になっているためです。
「参照セル」をWindow_Attribute_icon01_ver5.6.1有効に切り替え、各パーツの0フレーム目に「参照セル」の設定を行ってください。

「参照セル」で設定しているセルが削除されている

「参照セル」を有効にしていても表示されていない場合、「参照セル」で設定しているセルが除外・削除されており、表示されなくなっている可能性があります。

絵が表示されない場合は、表示されていないパーツ、キーの「参照セル」の設定を再度確認し、セルが存在しない場合は再度設定をし直してください。

エフェクトパーツの画像が表示されない

配置したエフェクトパーツが、レイアウトウィンドウ上に正常に表示されない際は以下の項目をご確認ください。

エフェクトエディタ上でエフェクトが正常に表示されているか

表示されないエフェクトパーツをエフェクトエディタで開き、パラメータ>画像>参照セル に画像が設定されているか。
また、プレビューでエフェクトが正常に表示されているかをご確認ください。

この時点で絵が表示されていない場合、何らかの理由で画像が参照できなくなっている可能性があります。この場合は画像を再度設定し直してみてください。

例)エフェクトやセルマップの登録先フォルダが変わっている等、データの移動を行った際に発生する可能性があります。

エフェクトエディタでは表示されているが、エフェクトパーツが正常に表示されない

エフェクトが未設定になっている

エフェクトエディタ上で正常に表示されている場合、エフェクトパーツにエフェクトが設定されていない可能性があります。
sseeの移動などにより、sseeが参照できなくなったため、発生することがあります。

正常に表示されないエフェクトパーツを選択後、アトリビュートウィンドウのエフェクト欄にて表示するエフェクトを設定してください。

エフェクトの表示が終わった状態になっている

エフェクトパーツを非表示状態で配置し、アニメーションの途中で表示とした場合、エフェクトが途中から再生されたり、何も表示されないことがあります。
これは、非表示状態でもエフェクトパーツのアニメーションが再生されているためです。

アニメーションの途中から再生を行う場合は、エフェクトアトリビュートを設定して、当該フレームから再生するように調整してください。

エフェクトは再生されているが、設定している画像が白い四角状になってしまう

Ver.5.5.1以降より、セルマップの画像が2の累乗でない場合、正常に表示できなくなっております。
詳しくは下記をご覧ください。

以前使用していたバージョンがVer.5.5.0である

Ver.5.5.1以降、エフェクト制御の仕様が変更されました。
そのため、Ver.5.5.0 と同じパラメータを使用しても、同じように再生されないケースがあります。
エフェクトエディタで、再度パラメータ調整するようお願いします。

関連ページ

このエントリーは役に立ちましたか?