SpriteStudio 6 SDKの使い方

SpriteStudio 6 SDK には、各種ツールとSpriteStudioのデータを扱う上で便利なソースコードが含まれています。本ページではSpriteStudio 6 SDKに関する以下の項目を解説します。

  • SpriteStudio 6 SDKで使用するデータを制作する場合の注意点
  • 同梱されているツールについての解説
  • ソースコードを用いてツールをビルドする方法

SpriteStudio 6 SDK は、SpriteStudio 5 のデータには対応しておりません。
SpriteStudio 5 で作成したデータを使用される場合は、SpriteStudio Ver.6 で一度読み込んで対応フォーマットにコンバートするか、 SpriteStudio 5 SDK(GitHub) をご使用ください。


本ページでは以下のバージョンを使用、解説しています。

  • SpriteStudio 6 SDK Ver.1.3.2

【2019/9時点】最新は Ver.1.7.3 です。本ページで解説しているVer.1.3.2から大きく変わっています。
大変申し訳ございませんが、最新版でのビルド方法は以下のGitHubの資料をご確認ください。

目次

事前準備

データを作成する際の注意点

SpriteStudioでアニメーションの作成を始める前に、使用するアトリビュートをSpriteStudio 6 SDK で扱えるもののみに制限する必要があります。

「プロジェクト設定」の「互換性」で「SS6 SDK v.1.0.0」を選択します。

これにより、SpriteStudio  6 SDK 対応アトリビュートのみに制限されますので、コンバートが行えないなどの事故を防ぐことができます。

必ず互換性を確認・設定してからアニメーションを作成してください。

GitHubからSDKをダウンロードする

SpriteStudio 6 SDK から SpriteStudio 6 SDK をダウンロードします。
GitHubを活用している方はCloneにて取得いただけます。
本ページではGitHubを使わずにZIPをダウンロードして導入する方法をご紹介します。

  1. まずは SpriteStudio 6 SDK のGitHubにアクセスします。
  2. 「Clone or download」という緑色のボタンをクリックします。
    クリックするとダイアログが表示されるため、ここで「Download ZIP」を選択してください。
  3. SpriteStudio6-SDK-master.zip がダウンロードされますので、ZIPを展開してください。
    展開したファイルは、本説明は E:SpriteStudio6-SDK へコピーして説明を行います。

ツールについて

SpriteStudio 6 SDK には展開したToolsフォルダーに、zip形式で同梱されているツールがあります。各ツールの紹介と使用に関しての注意点を記載します。

Ss6Converter (Windows / Mac)

SpriteStudio 6 で制作されたデータを変換して、バイナリー形式の ssbpを作成するツールです。
出力される ssbp は、様々なニーズに合わせて使用されることを想定しています。

Ss6Converter のソースコードは、SpriteStudio 6 SDK に同梱しています。カスタマイズしてビルドすることで出力データの変更も可能です。コマンドプロンプト にてご使用ください。

ツールをそのまま使用して ssbp を生成し組み込む際には、ssbp のデータ解析、制御などをおこなうライブラリとして SS6ssbplib のご利用も検討ください。
使用方法については、SS6ssbplibの使い方 をご覧ください。

viewer_sample (Windows / Mac)

SpriteStudio Ver.6 で作成されたアニメーションを再生するビューワーのサンプルです。
viewer_sampleのソースコードは、SpriteStudio 6 SDK に同梱していますので、カスタマイズして使用することができます。

使用に関しての注意

Windows

はじめてツールを起動すると警告ウィンドウがが表示されることがあります。 
その場合は、詳細情報を開き、実行を行ってください。

このような警告ウィンドウが出てきたら「詳細情報」をクリックしてください。
詳細情報を押すとこのような表示になります。
「実行」を押して起動してください。

Mac

GitHubより直接ダウンロードした場合、macOSのバージョンによってはセキュリティにより起動できないケースを確認しております。
ツールのZIPファイルは、Gitクライアントを使用してクローンしていただき、ZIPを展開して起動してください。

SS6Converter、ビューアーをビルドする方法

SS6Converter、ビューアーを作る方法を紹介します。

以下の環境を使用しています。

  • Windows 10
  • Visual Studio 2017

目次

Visual Studio 2017 を準備する

Visual Studio 2017 を使用できるようにインストールをおこないます。
インストール方法については、Microsoft のページにてご確認ください。

CMake を準備する

Visual Studio 2017 のビルド環境構築、ビルドで必用になるライブラリ準備に使用する CMake のセッティングを行います。
CMakeのページにあるダウンロードより、Windows用の Installer をダウンロードしてインストールしてください。

ビルドに使用するライブラリを準備する

ビルドをおこなう際に、いくつかのライブラリを使用します。
ここでは使用するライブラリの導入方法と、ライブラリの準備について解説します。

GLEW

OpenGL Extension Wrangler Library (GLEW) の準備をおこないます。
今回は Downloads の Source から、glew-2.1.0.zip をダウンロードをおこなってください。Ver.2.1.0 で説明を行います。

ZIPを展開したファイル一式を E:glew-2.1.0 に置いて進めます。

CMake(cmake-gui)を起動します。
Where is the source code: の欄に 「E:/glew-2.1.0/build/cmake」
Where to build the binaries: の欄に「E:/glew-2.1.0/build/project」
を入力します。
「Configure」ボタンを押します。
フォルダ作成のダイアログが表示されますので、「Yes」を押します。

プロジェクト生成する Visual Studioのバージョン選択ダイアログが表示されますので

「Visual Studio 15 2017」
「Use default native compilers」
を選択して「Finish」を押します。

CMake上で処理がおこなわれますので、しばらく待ちます。

エラーが発生してしまった場合はVisualStudioにC++環境が含まれていない可能性があります。

処理が完了しました。
CMAKE_INSTALL_PREFIX の欄のValueを選択して「E:/glew-2.1.0/build/project」
と入力します。
「Generate」を押します。
処理が完了したら
E:glew-2.1.0buildproject を開いて
「glew.sln」というVisual Studio 2017 用のソリューションファイルが生成されていることを確認してください。
Visual Studio 2017 を起動します。
「ファイル」 > 「開く」 > 「プロジェクト/ソリューション」から
「glew.sln」を開きます。
ソリューションエクスプローラーで ALL_BUILD が選択されているのを確認します。

構成 : Debug

構成 : Release

それぞれの状態で、「ソリューションのビルド」を行ってください。

ビルド終了後
E:glew-2.1.0buildprojectlib フォルダーが作られ
E:glew-2.1.0buildprojectlibDebug フォルダーに
 glew32d.lib、libglew32d.lib
E:glew-2.1.0buildprojectlibRelease フォルダーに
 glew32.lib、libglew32.lib
のライブラリがビルドされていることを確認して準備完了です。

GLFW

Graphics Library Framework (GLFW) の準備をおこないます。
今回は、Download ページの 「Source packege」から、glfw-3.2.1.zip をダウンロードしてください。
Ver.3.2.1 で説明を行います。

解凍したファイル一式を E:glfw-3.2.1 に置いて進めます。

CMake(cmake-gui)を起動します。

Where is the source code: の欄に 「E:/glfw-3.2.1」
Where to build the binaries: の欄に「E:/glfw-3.2.1/project」
を入力します。

「Configure」ボタンを押します。

フォルダ作成のダイアログが表示されますので、「Yes」を押します。

プロジェクト生成する Visual Studioのバージョン選択ダイアログが表示されますので

「Visual Studio 15 2017」
「Use default native compilers」
を選択して「Finish」を押します。

CMake上で処理がおこなわれますので、しばらく待ちます。

エラーが発生してしまった場合はVisualStudioにC++環境が含まれていない可能性があります。

処理が完了しました。
CMAKE_INSTALL_PREFIX の欄のValueを選択して「E:/glfw-3.2.1/project」
と入力します。
「Generate」を押します。
処理が完了したら
E:glfw-3.2.1project を開いて
「GLFW.sln」というVisual Studio 2017 用のソリューションファイルが生成されていることを確認してください。
Visual Studio 2017 を起動します。
「ファイル」 > 「開く」 > 「プロジェクト/ソリューション」から
「GLFW.sln」を開きます。
ソリューションエクスプローラーでGLFW3のフォルダーにある「glfw」が選択されていることを確認
「プロジェクト」>「プロパティ」を選択します。

「glfw プロパティページ」が起動しますので。
左上の構成:が「Debug」になっていることを確認。
別の構成指定になっていたら「Debug」へ変更してください。

その後に、ターゲット名「glfw3」となっているものを「glfw3d」と変更してください。

変更が完了したら、「OK」を押して閉じてください。

構成 : Debug

となっているのを確認した後。
「glfwのビルド」を行ってください。

次に、構成 : Release に変更してください。

その後、もう一度「glfwのビルド」を行ってください。

ビルド終了後
E:glfw-3.2.1projectsrcDebug フォルダーに
 glfw3d.lib
E:glfw-3.2.1projectsrcRelease フォルダーに
 glfw3.lib
のライブラリがビルドされていることを確認して準備完了です。

AntTweakBar

UI ライブラリ AntTweakBar の準備をおこないます。
今回は Download ページから AntTweakBar_116.zip をダウンロードをおこない。
Ver.1.16 で説明を行います。

ダウンロードファイルは、展開してファイル一式を E:AntTweakBar にコピーしました。

ビルド環境を準備する

本説明ではダウンロードして展開したファイルは
E:SpriteStudio6-SDK にコピーされているとして進めます。

ソリューションファイルの作成

CMake(cmake-gui)を起動します。
Where is the source code: の欄に 「E:/SpriteStudio6-SDKBuild」
Where to build the binaries: の欄に「E:/SpriteStudio6-SDKBuildproject」
を入力します。

「Configure」ボタンを押します。

フォルダ作成のダイアログが表示されますので、「Yes」を押します。

プロジェクト生成する Visual Studioのバージョン選択ダイアログが表示されます。

「Visual Studio 15 2017」
「Use default native compilers」
を選択して「Finish」を押します。

CMake上で処理がおこなわれますので、しばらく待ちます。

処理が完了したら、

「Generate」を押します。

処理が完了したら
E:SpriteStudio6-SDKBuildproject を開いて
「sssdk.sln」というVisual Studio 2017 用のソリューションファイルが生成されていることを確認してください。

viewer_sample_dx9のビルド環境準備

Visual Studio 2017 を起動します。
「ファイル」 > 「開く」 > 「プロジェクト/ソリューション」から
「sssdk.sln」を開きます。
次に「viewer_sample_dx9」のビルド環境を設定します。
ソリューションエクスプローラーで「viewer_sample_dx9」を選択してください。
「プロジェクト」>「プロパティ」を選択します。
「viewer_sample_dx9 プロパティページ」が起動しますので。
左上の構成:を「すべての構成」に変更します。
構成プロパティのツリーから「 C/C++」 を開いて「全般」を選択。
表示された項目の「追加インクルードディレクトリ」の右隅をクリックして
プルダウンメニューを表示 <編集…> を選択します。
「追加のインクルードディレクトリ」が開きますので、
E:AntTweakBarincludeを加えて、OKを押して閉じてください。
次に構成プロパティツリー「リンカー」を開いて、「全般」を選択
表示された項目の「追加ライブラリディレクトリ」の右隅をクリックして
プルダウンメニューを表示 <編集…> を選択します。
「追加のライブラリディレクトリ」が開きますので、
E:AntTweakBarlibを加えて、OKを押して閉じてください。
右下の「適用」ボタンを押して、いまの状態をプロパティに反映してください。
これで「viewer_sample_dx9」のビルド環境が整いました。
完了となります。
「OK」を押して「viewer_sample_dx9 プロパティページ」を閉じてください。

viewer_sample_glのビルド環境準備

「viewer_sample_gl」のビルド環境を設定します。
ソリューションエクスプローラーで「viewer_sample_gl」を選択してください。
「プロジェクト」>「プロパティ」を選択します。
「viewer_sample_gl プロパティページ」が起動しますので。
左上の構成:を「すべての構成」に変更します。
構成プロパティのツリーから「 C/C++」 を開いて「全般」を選択。
表示された項目の「追加インクルードディレクトリ」の右隅をクリックして
プルダウンメニューを表示 <編集…> を選択します。
「追加のインクルードディレクトリ」が開きますので、
E:AntTweakBarinclude
E:glew-2.1.0include
E:glfw-3.2.1include
を加えて、OKを押して閉じてください。
右下の「適用」ボタンを押して、いまの状態をプロパティに反映してください。
次に、左上の構成:を「Debug」に変更してください。
次に構成プロパティツリー「リンカー」を開いて、「全般」を選択
表示された項目の「追加ライブラリディレクトリ」の右隅をクリックして
プルダウンメニューを表示 <編集…> を選択します。
「追加のライブラリディレクトリ」が開きますので、
E:AntTweakBarlib
E:glew-2.1.0buildprojectlibDebug
E:glfw-3.2.1projectsrcDebug
を加えて、OKを押して閉じてください。
右下の「適用」ボタンを押して、いまの状態をプロパティに反映してください。
次に、左上の構成:を「Release」に変更してください。
次に構成プロパティツリー「リンカー」を開いて、「全般」を選択
表示された項目の「追加ライブラリディレクトリ」の右隅をクリックして
プルダウンメニューを表示 <編集…> を選択します。
「追加のライブラリディレクトリ」が開きますので、
E:AntTweakBarlib
E:glew-2.1.0buildprojectlibRelease
E:glfw-3.2.1projectsrcRelease
を加えて、OKを押して閉じてください。
右下の「適用」ボタンを押して、いまの状態をプロパティに反映してください。
これで「viewer_sample_gl」のビルド環境が整いました。
完了となります。
「OK」を押して「viewer_sample_gl プロパティページ」を閉じてください。

ビルドを実行する

SpriteStudio 6 SDK のビルドを行います。

Visual Studio 2017 を起動します。
「ファイル」 > 「開く」 >  「プロジェクト/ソリューション」から
「sssdk.sln」を開きます。

今回は、「Debug」のビルドを行います。
設定を確認してください。

「ビルド」>「ソリューションのビルド」を実行します。

ビルドが終了するのを待ちます。

エラーが発生した場合は、エラーへの対応方法を確認ください。

次に、「Release」のビルドを行います。
構成を Release に変更します。
「ビルド」>「ソリューションのビルド」を実行します。

ビルドが終了するのを待ちます。

エラーが発生した場合は、エラーへの対応方法を確認ください。

正常終了後、

E:SpriteStudio6-SDKBuildprojectDebug フォルダーに
Ss6Converter.exe
viewer_sample_dx9.exe
viewer_sample_gl.exe

E:SpriteStudio6-SDKBuildprojectRelease フォルダーに
Ss6Converter.exe
viewer_sample_dx9.exe
viewer_sample_gl.exe

が生成されているのを確認して完了です。

エラーへの対処法

CMakeでエラーが発生してしまう場合

ビルドに使用するライブラリを準備しているときに「Configure」でエラーが発生した場合、Visual Studio にC++がインストールがされていない可能性があります。

ヘルプ > Microsoft Visual Studio のバージョン情報を選択してバージョン情報を開きます。
製品の詳細にMicrosoft Visual C++ 2017が入っているかご確認ください。

入っていない場合、インストールを行ってください。

Visual Studioのメインメニュー「ツール」から「ツールと機能を取得」を選択します。

「C++によるデスクトップ開発」にチェックを入れ、インストールを行ってください。

インストールが完了したら再度CMakeで処理を行ってみてください。

warning C4819 警告が発生していた場合

warning C4819: ファイルは、現在のコード ページ (932) で表示できない文字を含んでいます。データの損失を防ぐために、ファイルを Unicode 形式で保存してください。

という警告が表示された場合、指摘されたファイルを正常に読み込めず、他のエラーが誘発されているケースがあります。
この警告が表示された場合、ツールなどでソースファイルの文字コードを全て
 Unicode (UTF-8 シグネチャ付き)
に変換して保存してください。

Visual Studio 2017 上で修正を行う場合、下記のような手順で行います。

warningの発生しているファイルを見つけます。
warning の発生している行をダブルクリックして該当ファイルを開きます。
他の方法で開いても問題ありません。
「名前を付けて ファイル名 を保存」を選択します。
「名前を付けてファイルを保存」ウィンドウが開きます。
「上書き保存」の横を押してメニューを表示させて
「エンコード付きで保存」を選択します。
「名前を付けて保存の確認」ウィンドウが開きますので、「はい」を選択します。

「保存オプションの詳細設定」ウィンドウが表示されます。

エンコードを
「Unicode (UTF-8 シグネチャ付き) – コードページ 65001」
に変換して「OK」を選択して保存します。

一連の手順を、
warning C4819 が発生しているファイル全てでおこないます。
これで完了です。

その他のエラーの場合

warning C4819 を全て解消しても、何らかのエラーが発生しているなどありましたら、お手数ですが、GitHub issues にてご報告ください。

SpriteStudio 6 SDK issues

ビルドされたアプリケーションを実行する

ビルドしたアプリケーションを実行するにあたり、一部環境を整える必用がありますので、
それについて説明します。

ビルドして生成しました、
 viewer_sample_dx9.exe
 viewer_sample_gl.exe
について動作に必用な dll をそれぞれのフォルダーへ準備する方法を案内します。

  1. E:AntTweakBarlib フォルダーにある「AntTweakBar.dll」を
    E:SpriteStudio6-SDKBuildprojectDebug
    E:SpriteStudio6-SDKBuildprojectRelease
    のそれぞれのフォルダーにコピーします。
  2. E:glew-2.1.0buildprojectbinDebug フォルダーにある「glew32d.dll」を
    E:SpriteStudio6-SDKBuildprojectDebug
    へコピーします。
  3. E:glew-2.1.0buildprojectbinRelease フォルダーにある「glew32.dll」を
    E:SpriteStudio6-SDKBuildprojectRelease
    へコピーします。
  4. 以上で作業完了です。

上記準備を行い、正常に動作しない場合は、Debugにて挙動を確認いただき、実行環境に適した調整をおこなってください。
また、プログラムに不具合などありましたら GitHub Issues へご投稿いただければ幸いです。

関連ページ

SpriteStudio 6 SDK
最新版、質問・要望は GitHubへ

このエントリーは役に立ちましたか?