Version 8.10.0 リリースノート(2024/02/13)

対応ファイル形式とご使用の際の留意点

特に記載が無い場合は Windows版・Mac版共通です。

    主要機能の強化

     [アニメーション形式画像に対応]

    • 「アニメーションGIF」「アニメーションPNG(APNG)」「アニメーションWebP」「アニメーションAVIF」ファイルの読み込み・保存に対応しました。
    • 「ファイル」メニューに「インポート」-「連番アニメーションファイル」機能を追加し、ファイル名が連番になっている複数ファイルを最大999枚まで「アニメーション形式」として読み込めるようにしました。
    • マルチレイヤーおよびアニメーション形式の編集機能をまとめた「レイヤー/アニメ」メニューをメインメニューに追加しました。

     [リマスター超解像の強化]

    • 使用エンジンの「特殊(Clear RealESRGAN)」で対応する画像の種類に、セルアニメーションに適した「アニメ動画系」を追加しました。
    • 「超解像処理の前に透明境界の色漏れ予防処理を行う」オプションを追加しました。
    • 設定に「リセット」ボタンを追加しました。

      新機能の追加

      • 「連結貼り付け」機能を「編集」メニューに追加しました。
      • 「連結イメージ生成」機能を「ツール」メニューに追加しました。

        既存機能の強化

         [マクロ関連]

        • 「マクロの読み込み」「マクロの保存」ボタンに履歴のプルダウンメニューを追加し、マクロファイルの再編集と上書き保存の操作性を改善しました。
        • 「マクロの編集と実行」ダイアログを閉じるとき、常に設定内容を保持するようにしました。なお、「閉じる」ボタンのプルダウンメニューから、変更を破棄して閉じることも可能です。
        • 入力として「ドロップしてファイルまたはフォルダーを指定」を選択した場合に開く「入力ファイルの指定」ダイアログに、「ファイルを参照」「フォルダーを参照」ボタンを追加し、ファイルやフォルダーを直接選択・追加することも可能にしました。

         [アクション関連]

        • 「タイムライン」メニューに「すべてのファイルに対して」を追加しました。開いているすべての画像に対して、「アクションの貼り付け」「アクションの読み込み」を一括で実行可能です。
        • 編集・加工処理後の「アクション内容の変更」を、Ctrl+I および F3 キーでも実行可能にしました。

         [その他]

        • 編集ウィンドウ上部のサブツールバーに「選択色ブリンク」ボタンを追加しました。長押しすると選択色が点滅します(Shiftキーも押すと色反転)。
        • 「表示」メニューに「表示チャンネル」-「合成表示では全レイヤーをブレンド」を追加しました。マルチレイヤー形式の画像で「合成表示」にしているとき、ONなら全レイヤーをブレンド表示し、OFFなら可憐とレイヤーのみを表示します。
        • マルチレイヤー・アニメーション形式の画像を、マルチレイヤー・アニメーション非対応の形式で保存する場合に表示される「マルチレイヤー画像の保存設定」ダイアログで、「レイヤーを個別のファイルに分離して保存する」を選んだ場合の設定に「レイヤーサイズを揃える」オプションを追加しました。
        • 「キャンバスサイズ変更」の「新しいサイズ」の設定に「縦横サイズを単位値の倍数に揃える」を追加しました。「単位値」として 2,4,8,16 が選択可能です。
        • KTX形式の保存オプションに「ETC1・ETC2では縦横サイズを4の倍数に揃える」を追加しました。

          その他の改良

          • 編集ウィンドウのタイトルに、画像の圧縮形式も表示するようにしました。
          • 「プロパティ」に、編集中の画像が使用しているRGBA階調(※圧縮形式ではありません)の表示を追加しました。
          • 「カラーチャート」のチャート部で、現在のRGB値の位置にマークを表示するようにしました。
          • 編集画面で選択領域をドラッグ捜査中は、中心にマークを表示するようにしました。
          • 「比較表示タイプ」を「スライド」にしている場合で、処理前後の縦横サイズが異なってスライド比較が使用できない状態では、スライダーを編集画面の左端に表示するようにしました。
          • フローティング状態のツールウィンドウへ画像ファイルをドロップした場合でも開けるようにしました。
          • 編集画面上部のサブツールバーにある「ズームアウト」ボタンにプルダウンメニューを追加し、表示倍率を直接選択可能にしました。
          • 画像を何も開いていないときの編集画面に、「主なマウスとキーの操作」の一覧を表示するようにしました。
          • 「環境設定」の「一般設定」に、「起動時にアンケート協力のお願いを表示しない」を追加しました。

            動作仕様変更

            • 「マクロの編集と実行」の「高度な設定」ページを「環境別設定」に名前変更し、ページ内の設定をマクロファイルではなくユーザー環境ごとに保存するようにしました。過去に作成したマクロファイルで「別プロセスとして起動」「処理優先度を下げる」をONにしていた場合でも無視されるのでご注意ください。
            • ダイレクトカラー画像は、直接GIF形式に保存できないようにしました。GIF形式で保存する場合は、あらかじめインデックスカラーへ減色しておく必要があります。
            • WebP形式の保存オプションダイアログで、「ニアロスレス」か「ロッシー」を選択している場合は、「完全透明領域のRGB値を維持する」は無効(常にOFF)として扱うようにしました。

              不具合修正

              • アルファチャンネルの無い画像を、「減色」の「RGBA階調変換」で「RGBA 4444」「RGBA 5551」に変換した場合に、アルファチャンネルが付加されない不具合を修正しました。
              • マクロ処理の「単独機能実行」の「共通パレット減色」で、「アルファチャンネル継承」と「透過色」の設定が正常に動作していなかった不具合を修正しました。
              • 「減色」「拡大縮小」や各種フィルターなどの設定ダイアログが開いている状態で、他に開いている画像へ切り替えることができてしまう(処理がキャンセルされてしまう)不具合を修正しました。

              関連ページ