Version 5.8.0

ダウンロード  ダウンロード * Sierra, El Capitan, Yosemite対応

新機能

セルリスト

  • セルをグループ分けして管理できるタグ機能を追加しました。

追加要素

レイアウト

  • セルをドロップした時にパーツが追加されるツリーの位置を指定できるようにしました。(「環境設定」で変更します)
  • 奥(手前)にあるパーツを選択するコマンドを追加しました。デフォルト設定では、[ キーで1つ奥を、] キーで1つ手前を選択します。

フレームコントロール

  • ラベルの複数/一括削除を追加しました。
  • ステータスバーに現在のアニメーションに含まれる「パーツ数」を表示するようにしました。

セルマップ

  • テクスチャの設定状況を常時表示し、設定変更へのアクセス(右クリックメニュー)を追加しました。
  • UVアニメの適用状況を表示し、マウスで操作できるようにしました。

セルリスト

  • 使われていないセルを選択する機能を追加しました。(右クリックメニューの「未参照のセルを選択」)
  • 選択しているセルを参照しているパーツを選択する機能を追加しました。(右クリックメニューの「アクティブセルを参照しているパーツを選択する」)
  • 英数字キーを押すことで、セル名の先頭に一致したセルにジャンプするようにしました。
  • 「ソート」ボタンを追加しました。
  • エフェクトファイルから参照されているセルを削除する際に警告メッセージを表示するようにしました。

ユーザーデータの編集

  • 「前回更新時の値を設定」ボタンを追加しました。

頂点変形の編集

  • 全ての値を0にする「リセット」ボタンを追加しました。

レンダリング

  • 「中止」ボタンを追加しました。

複数アニメーションの重ね描画

  • 操作性全般を大幅に改善し、各アニメーションの透明度を指定できるようにしました。

環境設定

  • プロジェクト:「ファイルを削除する前に確認する」、「取り消しができない操作を実行する前に確認する」を追加しました。
  • セルリスト:「タグのフォントサイズ」、「セル名の先頭文字に一致する英数字キーを入力して該当セルにジャンプする」を追加しました。
  • レイアウト:「セルをドロップした時にパーツが追加されるツリーの位置」を追加しました。
  • 編集:「パーツ追加時はアニメファイル内の全アニメにデフォルトのキーを設定する」を追加しました。
  • その他:コマンド履歴をログファイルに出力する(デバッグ用)を追加しました。

プロジェクトの設定

  • デフォルト設定→新規作成アニメーションに、総フレーム数と単位時間の指定を追加しました。

セルマップの設定

  • 「プロジェクトのデフォルト設定」を開くボタンを追加しました。

編集→パーツメニュー

  • 選択パーツの、可視状態、ロック状態をOn/Offするコマンドを追加しました。
  • メニューの構成を可視・ロック別でサブメニュー化しました。

その他

  • プロジェクト設定の「Ver.4 互換機能に制限する」が、On の場合、メインウィンドウ上部右に、”Ver.4″ という表示を行うようにしました。

改善点

フレームコントロール

  • タイムスライダーの位置をアニメーションごとに記憶するようにしました。
  • 「エフェクトパーツの追加」ボタンを追加しました。
  • ツリーの▼、[+] をクリックした時に、選択パーツすべてを対象に展開/折り畳みするようにしました。
  • [mac] キー選択の追加、解除 は ctrl キー以外に command キーでもできるようにしました。
  • 「現在のパーツ以外を可視 / 不可視にする」実行時の、挙動を Photoshop 準拠に変更しました。
  • 「再生区間情報の指定」方法を改善しました。
    • Shift キーを押してから左ドラッグで範囲選択可能。
    • ウィンドウ外にドラッグした場合、スクロールする。
    • 開始点より左にドラッグして範囲延長可能。

レイアウト

  • fps(statsに変更), information, time タブを半透明にして背後が見えるようにしました。
  • information タブの各項目を左クリックで選択でき、またParentalRelation は左クリックでOn/Offするようにしました。
  • アクティブパーツの頂点を、Ctrl + 左クリックした場合、回転ハンドルを無視して頂点変形の指定を優先するようにしました。
  • 通常パーツ以外のパーツ選択枠を通常パーツと同様にして、ハンドルでX/YスケールとZ軸回転を指定できるようにしました。
  • 選択パーツをCtrl + 左クリックすることで選択を解除できるようにしました。
  • [mac] 下記の操作時は、control キー押下以外に command キー押下にも対応しました。
    • パーツの選択、頂点変形、パーツ追加時にタイムスライダー位置にキーを作るオプション。

セルマップ

  • 選択範囲を矢印キーでウィンドウ外に移動した場合スクロールするようにしました。
  • 未確定の範囲選択を矢印キーで移動した場合は「セル編集」を開かないようにしました。
  • [mac] ctrl キー以外に command キーでもグリッドにスナップしないようにしました。

セルリスト

  • セルの複数選択、すべて選択(Ctrl + A)に対応しました。
    • 複数選択したセルを対象に、削除や、タグの指定・クリアができます。

セル編集

  • ?ボタンの位置を少し下に移動しました。
  • 原点指定領域(黄色の十字がある領域)にフォーカスが無い時に、同領域で左クリックした場合は、原点を移動せずフォーカスが移るのみにしました。
  • [mac] ズームイン/アウトの+/- は ctrl キー以外に command キー押下でも対応しました。

参照セル選択

  • ウィンドウのサイズを記憶するようにし、1セルの表示高さをセルリストの高さと同じにしました。

カーブエディタ

  • カレントフレームにキーが無くても値ボックスに補間値を表示するようにしました。
  • ?ボタンの位置を少し下に移動しました。
  • [mac] スクロール、キーの追加選択は、ctrl キー以外に command キー押下にも対応しました。
  • [mac] メインウィンドウの最小化に応じて非表示にするようにしました。

ユーザーデータの編集

  • モードレスダイアログに変更し開いたまま編集できるようにしました。
  • 開いた状態でUndo/Redo 可能です。(※文字列入力だけは Redo できません)
  • 左端のチェックを入れなくても直接、値を入力できるようになりました。
  • Enter 押下で確定し、次の入力項目へフォーカスします。
  • ウィンドウの位置・サイズを記憶し、復帰するようにしました。
  • ユーザーデータのキーの新規作成時は、前のキーを複製せず初期値で設定するよう変更しました。
  • タブオーダーを揃えました。

プロジェクト

  • 「フォルダ」タブで右メニューの新規作成はいずれも3種類のファイルを選択できるようにしました。
  • 新規作成時のファイル保存ダイアログの初期フォルダは選択中のフォルダ、または選択中のファイルのあるフォルダ位置にしました。
  • 別のアニメーションを選択した時に、同一の ssae ファイル内であればroot パーツに移動しないようにしました。

アトリビュート

  • 絶対値入力ボックスにフォーカスしている場合のみマウスホイールで値を変更できるようにしました。

レンダリング

  • AVI出力でファイルサイズが4GBを越えた場合は、警告を出すようにしました。

エクスポート

  • プロジェクト設定の「エクスポート」ページを開く「プロジェクトの設定」ボタンを追加しました。

プロジェクトの設定

  • 互換性→デフォルト(基本項目を有効)選択時に、UVアニメ系アトリビュートをすべて有効にしました。
  • その他→「パーツ単位のキー作成時に設定されるアトリビュート」の出荷時設定で優先度を On に変更しました。

「ウィンドウ」メニュー

  • レイアウト→「配置を保存」で任意の名前を指定できるようにしました。

ファイル保存ダイアログ

  • [Windows] ファイル名入力ボックスには拡張子を含めず名前のみにしました。

アニメーションの編集

  • パーツの追加・複製時に同SSAE内の他のアニメにも初期アトリビュート(通常パーツなら参照セルも)のキーを0フレームに追加するようにしました。
    • 環境設定:「パーツ追加時はアニメファイル内の全アニメにデフォルトのキーを設定する」がOn の場合のみ有効です。

ファイル保存

  • ファイルの作成、保存に関連する処理で失敗した場合、エラーコードと原因を示すメッセージをログ及びダイアログに表示するようにしました。

ファイル削除

  • ファイルの削除は完全な削除ではなく、ゴミ箱に移動する処理に変更しました。

ファイル読み込み

  • 補間を適用できないアトリビュートに何らかの補間が指定されていた場合、該当箇所を修正し、警告を出すようにしました。
  • まとまったファイル読み込み、書き込み処理が行われた後の警告・エラー通知メッセージのボタンを「はい」「いいえ」から「ログファイルを開く」「閉じる」に変更しました。

ショートカットキー設定

  • 本体起動時に、ユーザー設定ファイル(SSフォルダにあるSsKeyBindings.xml)に存在しないコマンドがあった場合、自動で追加するようにしました。

その他

  • パーツ・セル・アニメの追加・複製・リネーム時に名前が既存のものと重複した場合の名前設定ロジックを改善しました。
    • 例) NewName_1 を複製した場合、NewName_1_1 になっていたのを NewName_2 になるよう修正しました。
    • 各種ファイルの新規作成、複製、名前を付けて保存、実行時の初期名も同様です。
  • 数値入力ボックスのドラッグで値変更せず、範囲選択できるようにしました。
    • 対象:レンダリング・スプライトシート生成・複数アニメーションの重ね描画・アニメーション尺の調整・カラーピッカー
  • 使用統計情報の送信機能を追加しました。詳しくは、「ヘルプ」→「使用統計情報の送信について」を開いてご確認ください。

不具合修正

  • セル編集:[mac] 環境によってセルリストからダブルクリックで開いた時にクラッシュすることがある。
  • 全般:[Win10] 高DPI環境で画像が小さくなり、文字がコントロールからはみ出たりする。
  • フレームコントロール:ツリーのアトリビュート行をマウスの左クリックで選択した場合、カーブエディタの表示アトリビュートが変わらない。
  • フレームコントロール:ツリーでCtrlキー押下によるパーツ選択の追加/解除がレイアウト側に正しく反映されない。
  • ファイル読み込み::登録されているエフェクトファイルのパスにフォルダが入っている場合、登録されていないと誤認識され警告メッセージが出力される。
  • ファイル読み込み:プロジェクトおよび各種ファイルの新規作成時に失敗してもエラーが出ず、処理が続行する。
  • アニメ再生:エフェクトが参照しているセルを削除すると例外が発生する。
  • エフェクト選択:エフェクト未割り当てのパーツを対象にして開き、ESCキー押下で閉じて、再度開くとフリーズする。
  • エフェクトエディタ:2回開き、Spaceキー押下後に閉じると例外が発生する。
  • レイアウト:グリッドカラーにアルファ値が反映されない。
  • セルリスト:レイアウトウィンドウを閉じた状態でアニメリストに切り替えると操作不能になる。
  • セルリスト:エフェクトファイルから参照されているセルを削除した状態で、当該エフェクトファイルを保存すると例外が発生する。
  • その他:Windows 10でメインウィンドウが前回起動時より下にずれて表示される。
  • カラーピッカー
    • Tab キーで次の項目に移動しない。
    • 数値入力ボックス内が残り1文字の場合削除できない。
    • 閉じた時にチラつく。

既知の不具合

  • [mac] OSX 10.12 Sierra では、日本語モードに設定していてもコンテキストメニューなどの一部が英語表記になる問題があります。