OPTPiX SpriteStudio Ver.6 Releasenote

Version 5.8.0 Releasenote (Feb.7th, 2017)

New Features

Cell List

  • Added a feature that enables you to organize cell with your custom tags.

Additions

Layout

  • Added an option to change a part position in the tree when you add the part. (in Environmental Settings)
  • Added commands to select a backward or foreward part from the current part.
    • By default, pushing [ key to select the backward, ] key to select the forward.

Frame Control

  • Added commands to delete labels in playback range or all labels.
  • Added the number of parts in a current animation on the status bar.

Cell Map

  • Added a texture filter and wrap mode on the overlay and an access to the settings in the context menu.
  • Now you can see the cell frame applied UV animation and manipulate UV attributes by mouse dragging.

Cell List

  • Added a command to select unreferenced cells on the context menu.
  • Added a command to select the parts referring to an active cell on the context menu.
  • Pushing the alphabet or numeric keys allows you to jump to the cells whose name begins the character pushed.
  • Added Sort button.
  • A warning popups when you delete a cell referenced from some effects.

Edit User Data

  • Added “Set Last Updated Value” button.

Edit Vertex Deformation

  • Added “Reset” button which resets all values to zero.

Rendering

  • Added “Abort” button which can cancel process while rendering.

Multi Animation Preview

  • Added an opacity for each animation and improved UI in whole.

Environmental Settings

  • Project: Added options to toggle showing confirmation before deleting a file and performing not undoable operation.
  • Cell List: Added “Cell tag font size” and “Enable jump to a cell which name starts with input key.”
  • Layout: Added “Tree position where parts add by dropping cell.”
    Edit: Added “Set default keys for all animations in a file when you add/duplicate a part.”
  • Other: Added “Log command history (for debug).”

Project Settings

  • Default Settings -> New Animation: Added the number of total frames and FPS.

Cell Map Settings

  • Added “Project Default Settings” button.

Edit -> Parts Menu

  • Added commands to toggle visibility or lock status of the selected parts.
  • Classified items by visibility and lock.

Others

  • Added “Ver.4” indicator which is shown on the top right of the main window if the “Limit to Ver.4 compatible functions” in the project settings is checked.

Improvements

Frame Control

  • Memorize time slider position for each animation.(not saved in the file)
  • Added “Add Effect Parts” button.
  • Fold/Expand all of selected parts when you click ▼ or [+] button on the tree.
  • [mac] Adding/deleting a key is invoked by pressing command key, not only control key.
  • Changed “Show/Hide Other Parts” behavior to the Photoshop’s rule.
  • Improved the followings about playback range:
    • Starts selection by pressing Shift key before left click dragging.
    • Scrolls when you drag to the outside the window.
    • Expands selection by dragging to the left of the beginning.

Layout

  • Made fps(changed to stats), information and time tabs semi-transparent to be able to see background behind the tabs.
  • Each item can be selected on information tabs by left-clicking and also “ParentalRelation” can be toggled.
  • Corner handle is now prioritized than rotation handle when left-clicking with Ctrl key on the active part.
  • Not normal typed parts can also be handled X/Y scale and Z rotation in the same way as the normal.
  • Deselect parts by Ctrl + left-clicking.
  • [mac] Command key is now recognized as same as Ctrl key to do the operations below:
    • Select parts, Vertex Deformation, Option to add keys on time slider position when adding parts.

Cell Map

  • Scrolls when moving selection to the out of the window by pushing arrow key.
  • Not open “Edit Cell” if moving unfixed selection by pushing arrow key.
  • [mac] Command key is now recognized as same as Ctrl key to snap grid.

Cell List

  • Supported multiple selection.
    • Delete, select tag and clear tags can be applied to the selection.
    • Ctrl + A to select all.

Edit Cell

  • Shifted “?” button downward to avoid accidental click.
  • When left-clicking pivot area without focus, not modify the pivot but just move the focus to the area.
  • [mac] Command key is now recognized as same as Ctrl key to zoom in/out.

Select Reference Cell

  • Memorizes window size.
  • Fits item height to the setting of Cell List.

Curve Editor

  • Interpolated value always shows even if there is no key on the current frame.
  • Shifted “?” button downward to avoid accidental click.
  • [mac] Command key is now recognized as same as Ctrl key to scroll and to add key selection.
  • [mac] Hides along with main window when miniaturization.

Edit User Data

  • Changed window type to modeless to be able to edit, undo and redo while opening.
    * String cannot be redoable.
  • Values can be acceptable without checking leftmost checkbox.
  • Pushing Enter key fixes value and move focus to the next.
  • Memorize window position and size.
  • Initial value does not take over a previous key value when creating a new key.
  • Sorted tab order.

Project

  • Added three file types in “New” command in the context menu in the “Folder” tab.
  • Changed initial folder of save file dialog to the selected folder or the folder contains the selected file.
  • When changing an other animation, active part focus stays if the animation is in the same SSAE file.

Attribute

  • Enabled to change value by mouse wheel while focusing absolute value input box.

Rendering

  • Notifies when avi file size gets over 4GB.

Export

  • Added “Project Settings” button to shortcut to “Export” page in the project settings.

Project Settings

  • All UV related attributes becomes available when “Default” is selected in Compatibility page.
  • Added “Priority” in “Attributes created when creating a key for each part” by factory setting.

Window Menu

  • Layout name can be specified from “Save Layout”.

Save File Dialog

  • [Windows] Removed extension in file name input box because accidental change may occur.

Animation Edit

  • When adding or duplicating parts, initial attribute(reference cell if normal part) keys are added at zero frame in the other animations in the same SSAE file.
    • Enabled if “Set default keys for all animations in a file…” is checked in Environmental Settings.

File Saving

  • Added an error code and its reason in the message dialog for investigation when failing to create or save a file.

File Deletion

  • Changed file deletion behavior from complete deletion to moving to the trash.

File Loading

  • When an uninterpolatable attribute having some interpolation type is found, fixes it and shows a warning.
  • When warning/error message dialog shows after loading/saving multiple files, shows “Open Log File” and “Close” buttons instead of “Yes”/”No” buttons.

Shortcut key setting

  • Added a new command automatically if user setting does not contains it yet when SpriteStudio boots up.

Others

  • Improved naming logic if the name is overlapped with the existings when creating/duplicating/renaming the name of part/cell/anime.
    • e.g.) Duplicating “NewName_1”, now you get “NewName_2” instead of NewName_1_1.
    • The logic also applies to the files.
  • Now left click dragging in the number input box performs selection normally instead of changing value.
    • In Rendering, Make Sprite Sheet, Multi Animation Preview, Scale Animation Length and Color Picker.
  • Added a function to send usage statistics.
    • Please go to “Help” -> “About sending usage statistics…” for more information.

Fixes

  • Edit Cell: [mac] Crashes sometimes when opening by double-clicking on Cell List.(depends on environment)
  • General: [windows 10] Characters run off and images shrink on High DPI environment.
  • Frame Control: Current attribute of Curve Editor does not change by left clicking the attribute line on the tree.
  • Frame Control: Selecting or deselecting parts by pressing Ctrl key on the tree does not reflect the change to Layout.
  • File Loading: When an effect file path contains folder path, a warning shows due to misunderstanding.
  • File Loading: An operation continues even after creating a project or a file is failed.
  • Animation Playback: An exception occurs when the cell referenced an effect is removed while playing the animation including the effect.
  • Select Effect: Open the effect which is not assigned any effect yet and close the window by pushing ESC key and then reopen the window, SpriteStudio freezes.
  • Effect Editor: Open two times and push Space key and then close, an exception occurs.
  • Layout: Grid color cannot be applied alpha value.
  • Cell List: When switching to Anime List while closing Layout window, SpriteStudio becomes no operation.
  • Cell List: An exception occurs when an effect file is saved after deleting the cell referenced from the effect file.
  • Other: [windows 10] Main window sometimes appears a bit downward than before.
  • Color Picker:
    • Tab key does not work to move the focus the next item.
    • Number input box cannot be empty when the number of characters remained is one.
    • Flickering when closed.

Known Issues

  •  [mac] On OSX 10.12 Sierra, Some texts (context menu, etc) are always shown in English despite Japanese mode.