メインメニュー

メインメニューには「OPTPiX SpriteStudio」全体に対して操作を行うための機能が用意されています。 メインメニューはメニューバー(メニュー部)とツールバーの二つで構成されています。

本ページではVersion 5.8以降について解説しています。
Version 5.7以前についてはこちらをご覧ください。

Window_MenuBarAll_ver5.6.1_02


「ファイル」メニュー

プロジェクトファイルの読込・保存や、各種設定、「OPTPiX SpriteStudio」の終了などを行うためのメニューです。

Window_Menufile_ver5.7.0

新規プロジェクト 編集中のプロジェクトを閉じて、新しいプロジェクトを作成します。
プロジェクトを開く 既存のプロジェクトファイルを読み込みます。
プロジェクトを保存 現在作業しているプロジェクトの全てのデータを保存します。
プロジェクトの設定 現在作業している プロジェクトの設定を変更するためのウィンドウ を開きます。
プロジェクトを閉じる 現在作業しているプロジェクトを閉じます。
選択ファイルのみ保存 プロジェクト中で、現在選択されているアニメーションまたはセルマップを上書き保存します。
名前を付けて保存 プロジェクト中で、現在選択されているアニメーションまたはセルマップを別の名前を付けて保存します。
すべて保存 現在作成しているプロジェクト及びそのプロジェクトに存在している全てのデータを、上書き保存します。
環境設定 「OPTPiX SpriteStudio」の基本設定と、 新規にプロジェクトが作成される際の初期状態を設定するウィンドウ が開きます。

最近開いたプロジェクト

最近開いたプロジェクトファイルがリストアップされています。その中から読み込むプロジェクトファイルを選択することができます。
終了 「OPTPiX SpriteStudio」を終了します。

「編集」メニュー

コピー(カット)&ペーストや、操作のリトライ(アンドゥ・リドゥ)を行うためのメニューです。

Window_Menuedit_ver5.6.1

元に戻す

現在作業しているデータに対する操作を取り消し、一段階前の状態に戻します。

複数回実行すると、その回数分の操作を取り消した状態に戻ります。 ただし、元に戻すことができる回数には制限があります。

やり直し

「元に戻す」で取り消した操作を、もう一度やり直します。 複数回実行すると、その回数分だけの操作を再実行します。

ただし、元に戻すことができる回数には制限があります。 また、「元に戻す」を選んだ後で別の操作を行った場合、別の操作を行う前の操作を再実行することはできませんのでご注意ください。

切り取り

現在選択しているフレームコントロールウィンドウ内のパーツ、及び各ウィンドウにある文字や数字などをクリップボードにコピーした後、削除します。

コピーした対象は「貼り付け」で 別の箇所に貼り付けられます。

コピー

現在選択しているフレームコントロールウィンドウ内のパーツ、及び各ウィンドウにある文字や数字などをクリップボードにコピーします。

コピーした対象は「貼り付け」で別の箇所に貼り付けられます。また「切り取り」と異なり、対象は削除されません。

貼り付け

「切り取り」または「コピー」したデータを、指定位置に貼り付けます。

貼り付ける際に上書きとなるか追加となるかは、貼り付けを行う対象によって異なります。

削除 現在選択している対象、及び各ウィンドウにある文字や数字などを削除します。
アニメーション

現在作業しているアニメーションに対し、様々な編集を行います。

*リサイズ
「リサイズ」ウィンドウを開きます。
キーの設定されたXYZの座標位置にスケールをかける事が出来ます。一旦保存し、画像ファイルをそのスケールに合わせ大きくする事で作成しているアニメーションを崩さずサイズを大きくする事が可能です。(元のファイル自体を加工しますので実行前にはバックアップをお勧めします)

*無変化キーの削除
「無変化キーの削除」ウインドウが開きます。
アニメーション、対象アトリビュートを指定して、一括で無変化キーの削除が行えます。
無変化キーの削除とは、パーツのアニメーションの演出に影響が無いアトリビュートの削除を行う機能です。
アトリビュートが全て削除されたキーについては削除されます。この機能はファイルサイズの削減に役立ちます。

*参照先セルマップの変更
複数のセルマップに同名のセルパーツが存在する場合、セルマップを移し変える事ができます。なお、移動先のセルパーツ画像のサイズが違う場合、中心点は縦横比で調整されますのでご注意ください。

*アニメーション尺の調整
一度設定した総フレームを変更したときに、割合によりフレームのキーを均等に引き伸ばしたり間引いたりする機能です。
割り切れなかったり、縮めた際にキーが収まりきらず間引かれた場合は、動きが大きく変わってしまう場合がございますのでご注意ください。

パーツ

パーツに対し、可視 / 不可視の切り替えや、ロック、無変化キーの削除を行います。


*現在のパーツを可視 / 不可視にする 
現在編集しているパーツの可視 / 不可視に切り替えます。

※不可視に切り替えることでSpriteStudio上では非表示になりますが、データとして保存する際やレンダリング時は、不可視状態のパーツもすべて表示されますのでご注意ください。

*現在のパーツ以外を可視 / 不可視にする 
現在編集しているパーツ以外のパーツの可視 / 不可視を切り替えます。

*選択パーツのみ可視 / 不可視にする
現在選択しているパーツの可視 / 不可視を切り替えます。
あくまで「選択をしている」パーツのみが対象です。
選択しているパーツに属している子パーツは対象外となります。

*選択パーツを可視 / 不可視にする(子供を含む)
現在選択しているパーツの可視 / 不可視を切り替えます。
選択しているパーツに属している子パーツも対象となります。

*すべてのパーツを可視 / 不可視にする 
すべてのパーツを可視 / 不可視に切り替えます。

*現在のパーツ以外を可視 / 不可視にする
選択しているパーツ以外を可視 / 不可視に切り替えます。


*現在のパーツをロックする
現在編集しているパーツをロック状態に切り替えます。

*選択パーツのみロック / ロック解除する
現在選択しているパーツのロック状態を切り替えます。
あくまで「選択をしている」パーツのみが対象です。
選択しているパーツに属している子パーツは対象外となります。

*選択パーツをロック / ロック解除する(子供含む)
現在選択しているパーツのロック状態を切り替えます。
選択しているパーツに属している子パーツも対象となります。

*すべてのパーツのロックを解除する 
すべてのパーツをロック状態を解除します。


*無変化キーの削除
指定パーツに対して無変化キーの削除を行います。
無変化キーの削除とは、パーツのアニメーションの演出に影響が無いアトリビュートの削除を行う機能です。
アトリビュートが全て削除されたキーについては削除されます。
この機能はファイルサイズの削減に役立ちます。

ノート:下記の操作は「元に戻す」「やり直し」の対象にはなりません。ご注意ください。

  • セルマップに対しての「参照イメージの変更」以外のプロジェクトウィンドウ上で行われた全ての操作
  • セルマップウィンドウやレイアウトウィンドウでのツールバーボタン上で行える変更

「プロジェクト」メニュー

現在作業しているプロジェクトに対して、アニメーションやセルマップなどのデータファイルの入出力を行うためのメニューです。

Window_Menuproject_ver5.6.1

新規ファイルの追加

現在作業しているプロジェクトに、アニメーションやセルマップを新たに追加します。

* アニメーション
プロジェクトに新しいアニメーションを作成して追加します。

新規に作成するアニメーションファイル名を指定するダイアログが開きますので、ファイル名を指定して「保存」をクリックしてください。プロジェクトに新しいアニメーションが追加されます。

* セルマップ
プロジェクトに新しいセルマップを作成して追加します。

新規に作成するセルマップで使用する画像ファイルを選択するダイアログが開きますので、画像ファイルを選択して「開く」をクリックします。

次に、新規に作成するセルマップファイル名を指定するダイアログが開きますので、ファイル名を指定して「保存」を押すと、プロジェクトに新しいセルマップが追加されます。

既存ファイルの追加

既存プロジェクトのアニメーションやセルマップファイルを、作業中のプロジェクトに追加します。

現在のプロジェクトが格納されているフォルダ(「プロジェクトフォルダ」とします)以外にあるセルマップファイルを追加する際に、そのセルマップが使用している参照イメージがプロジェクトフォルダに無い場合、エラーとなります。

この場合、追加するセルマップファイルが参照しているイメージファイルを、プロジェクトフォルダにコピーしてから、目的とするセルマップファイルを追加するか、「インポート」機能を使用するようにしてください。

インポート

既存のssax(旧バージョン用アニメーションファイル)や参照イメージなどを、プロジェクトに新規に追加します。

インポートするssaxや参照イメージのファイルをを選択するダイアログが開きますので、目的のファイルを選択して「開く」をクリックします。

次に、選んだファイルを現在のプロジェクトに登録するためのダイアログが開きますので、ファイル名を指定して「保存」を押すと、指定したファイルのインポートが完了します。

エクスポート

現在作業しているプロジェクトから、指定したファイルをssax(旧バージョン用アニメーションファイル)で出力します。

エクスポートを行うには、プロジェクトウィンドウ上で対象のアニメーションかセルマップを選択してください。
何も選択されていない場合「エクスポート」を選択しても何も起こりません 。

出力されるssaxは、「SpriteStudio バージョン.4」と互換のものになりますので、下記のキーフレーム情報は出力されません。

  • キーフレームでの参照セルの変更
  • Z座標
  • Y軸回転/Z軸回転
  • Xアンカー/Yアンカー/Xサイズ/Yサイズ

エクスポート設定ウィンドウについて、詳しくはこちらをご覧ください。

すべてエクスポート

作業中プロジェクトの全てのアニメーションデータを、ssax(旧バージョン用アニメーションファイル)形式で、参照イメージファイルと同時に出力します。その際の制約事項については上記「エクスポート」と同様になります。

出力先フォルダは上記「エクスポート」の エクスポート設定ウィンドウ で指定したフォルダになります。未設定の場合は現在作業中のプロジェクトと同じフォルダに出力されます。

「アニメーション」メニュー

現在作業しているプロジェクトに対して、アニメーションの再生制御や画像出力を行うためのメニューです。

Window_Menuanimetion_ver5.6.1

再生制御

アニメーションの再生に関する操作を行います。

*先頭へ
アニメーションを先頭フレームまで戻します。
タイムライン領域のカーソル(黄色い縦棒)も先頭に戻ります。

*1フレーム前へ
アニメーションを現在位置から1フレーム戻します。
タイムライン領域のカーソル(黄色い縦棒)も1フレーム戻ります。

*再生/停止
アニメーションが停止状態になっている場合はアニメーションを再生し、再生状態になっている場合はアニメーションを停止します。

*停止
表示が再生状態になっている場合、再生を停止します。
アニメーションを停止した位置に、タイムライン領域のカーソル(黄色い縦棒)も移動します。

*再生
アニメーションを現在位置から再生します。

*1フレーム次へ
アニメーションを現在位置から1フレーム進めます。
タイムライン領域のカーソル(黄色い縦棒)も、1フレーム進みます。

*末尾へ
アニメーションを末尾フレームまで進めます。
タイムライン領域のカーソル(黄色い縦棒)も、末尾フレームに進めます。

*ループ
アニメーション再生時に、末尾フレーム到達後に停止するか、先頭に戻って再生を繰り返すかどうかを切り替えます。

スプライトシート生成 「スプライトシート生成」ウィンドウを開きます。
レンダリング 「レンダリング設定」ウインドウを開きます。

「ウィンドウ」メニュー

「OPTPiX SpriteStudio」各機能ウィンドウの表示・非表示などの設定を行うためのメニューです。

window_ver5-8

配置を保存

現在のウィンドウの配置を保存します。 保存は最大3つまで可能です。「レイアウト1」~「レイアウト3」の中から、保存先を選んでください。

保存先を選んだ後、レイアウト名を入力することができるダイアログが表示されます。
任意のレイアウト名を入力してください。

window_02_ver5-8

*レイアウト名入力欄
任意のレイアウト名を入力することができます。

*OK
入力したレイアウト名でウィンドウの配置を保存し、ダイアログを閉じます。

*キャンセル
編集内容を保存せずにダイアログを閉じます。

配置を復帰

ウィンドウを「配置を保存」で保存したレイアウトに配置しなおします。

「レイアウト1」~「レイアウト3」を選択すると保存しておいたレイアウトに、「出荷状態」を選択すると「OPTPiX SpriteStudio」の初期状態に配置されます。

プロジェクト

「プロジェクト」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

セルリスト

「セルリスト」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

セルマップ

「セルマップ」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

レイアウト

「レイアウト」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

フレームコントロール

「フレームコントロール」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

レイアウト情報

「レイアウト情報」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

アトリビュート

「アトリビュート」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

カーブエディタ

「カーブエディタ」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

ユーザーデータの編集

「ユーザーデータの編集」ウィンドウの表示・非表示を切り替えます。

チェックが付いている場合は表示、チェックが付いていない場合は非表示となります。

「OPTPiX Labs」メニュー

「OPTPiX Labs」で提供されている機能を使用したり、「OPTPiX Labs」のWEBサイトを参照できるメニューです。

Window_Menulabs_ver5.7.0

自動バックアップの設定

自動バックアップの設定ダイアログが開きます。

Window_Menulabs_autobackup_02_ver5.7.0

*クラッシュ時にバックアップを実行する
アクセス違反など、例外処理が発生してしまった際にバックアップを行います。

*自動バックアップを有効にする
「バックアップの間隔」で指定した時間が経過するたびに、現在編集をしているファイルを特定のフォルダに保存します。

*アイドリング中のみ実行する
一定時間操作を行っていない場合、バックアップを実行します。

*バックアップの間隔
バックアップを実行する間隔を分単位で設定します。

*保存先フォルダを開く
バックアップファイルを保存しているフォルダを開きます。

複数アニメーションの重ね描画 「複数アニメーションの重ね描画設定」ウインドウを開きます。
OPTPiX Labsとは?

ウェブブラウザを開き、OPTPiX Labsを表示します。

「ヘルプ」メニュー

「OPTPiX SpriteStudio」の使い方やライセンス情報などを確認・設定するためのメニューです。

help_ver5-8

ヘルプセンター ウェブブラウザを開き、OPTPiX SpriteStudioのヘルプセンターを表示します。
ショートカットキー一覧 ウェブブラウザを開き、ショートカットキーの一覧を表示します。 
ユーザーコミュニティ

ウェブブラウザを開き、OPTPiX SpriteStudio コミュニティを表示します。

Facebook グループ

ウェブブラウザを開き、OPTPiX SpriteStudio ユーザー助け合い所を表示します。(リンク先はFacebookとなっております)

ログファイルの場所を開く

ログファイル(SpriteStudio.log)が格納されているフォルダを開きます。

使用統計情報の送信について

SpriteStudioの使用統計情報の送信設定を行えます。

  • 使用統計情報は当社製品の機能強化・改良のために利用いたします。
  • 使用統計情報にはお客様固有の情報は一切含まれておりません。
  • 使用統計情報は保存フォルダにテキスト形式で蓄積した後、zip形式に圧縮して当社サーバーに送信されます。
    テキストエディタ等で送信内容をご確認いただけます。
Web Technology Update

「Web Technology Updateウィンドウ」を表示します。

最新版のご案内やWeb Technologyからの様々なお知らせをご覧いただけます。

Web Technology Updateの設定

アプリケーション起動時の 「Web Technology Updateウィンドウ」表示設定を行えます。

*表示しない
起動時に「Web Technology Updateウィンドウ」を表示しません。

*何か更新情報があった場合に表示する
新たに更新情報が追加された際に「Web Technology Updateウィンドウ」を表示します。

*プログラムのアップデート情報があれば表示する
OPTPiX SpriteStudioのアップデート情報がある場合にのみ「Web Technology Updateウィンドウ」を表示します。

ライセンス管理

「ライセンス管理」ウィンドウを開きます。

SpriteStudioについて

お使いのOPTPiX SpriteStudioのバージョン、有効期限、シリアルをご確認いただけます。

*OPTPiX SpriteStudioの製品ロゴ
クリックするとウェブブラウザを開き、製品ページを表示します。

*Web Technologyの会社ロゴ
クリックするとウェブブラウザを開き、弊社コーポレートページを表示します。

「ツールバー」

メインメニューのすぐ下にあるツールバーのボタン群は、使用頻度の高い機能へのショートカットの役割となっています。

Window_mainmenu_toolbar_ver5.6.1_01


新規作成
「ファイル」メニューの「新規プロジェクト」 と同じです。

開く
「ファイル」メニューの「プロジェクトを開く」 と同じです。
mainmenu_toolbar_icon03_ver5.6.1選択ファイルのみ保存する
「ファイル」メニューの「選択ファイルのみ保存する」 と同じです

mainmenu_toolbar_icon06_ver5.6.1すべて保存

 「ファイル」メニューの「すべて保存」 と同じです
mainmenu_toolbar_icon04_ver5.6.1元に戻す 「編集」メニューの「元に戻す」 と同じです。
mainmenu_toolbar_icon05_ver5.6.1やり直し 「編集」メニューの「やり直し」 と同じです。

関連ページ